rules 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162
  1. #!/usr/bin/make -f
  2. # debian/rules for the dpkg suite.
  3. # Copyright © 2004 Scott James Remnant <scott@netsplit.com>
  4. # Copyright © 2006-2012 Guillem Jover <guillem@debian.org>
  5. WFLAGS := -Wall -Wextra -Wno-unused-parameter -Wno-missing-field-initializers
  6. # XXX: Stack Protector Strong is only available in gcc >= 4.9
  7. cc_version = $(shell $(CC) -dumpversion 2>/dev/null)
  8. cc_version_lt = $(shell dpkg --compare-versions "$(cc_version)" lt-nl "$(1)" && echo yes)
  9. hardening_old = $(if $(call cc_version_lt,4.9),-stackprotectorstrong)
  10. # Use the in-tree dpkg-buildflags
  11. dpkg_buildflags = \
  12. DEB_BUILD_MAINT_OPTIONS="hardening=+all,$(hardening_old)" \
  13. DEB_CFLAGS_MAINT_APPEND="$(WFLAGS)" \
  14. DEB_CXXFLAGS_MAINT_APPEND="$(WFLAGS)" \
  15. $(CURDIR)/run-script scripts/dpkg-buildflags.pl
  16. DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
  17. DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
  18. DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
  19. DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
  20. # Support cross-compiling.
  21. ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
  22. confflags += --build=$(DEB_HOST_GNU_TYPE)
  23. else
  24. confflags += --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
  25. endif
  26. # Do not enable everything on all platforms.
  27. ifeq ($(DEB_HOST_ARCH_OS),linux)
  28. confflags += --with-libselinux
  29. endif
  30. ifeq (,$(filter maintainer-build,$(DEB_BUILD_OPTIONS)))
  31. confflags += --disable-silent-rules
  32. endif
  33. # Enable parallel test suite
  34. NUMJOBS = 1
  35. ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
  36. NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
  37. MAKEFLAGS += -j$(NUMJOBS)
  38. endif
  39. D := $(CURDIR)/debian/tmp
  40. # Create configure script if necessary, automake handles rebuilding it.
  41. configure:
  42. dh_testdir
  43. autoreconf -v -i
  44. # Configure the build tree
  45. build-tree/config.status: configure
  46. dh_testdir
  47. install -d build-tree
  48. cd build-tree && ../configure $(confflags) \
  49. $(shell $(dpkg_buildflags) --export=configure) \
  50. --prefix=/usr \
  51. --mandir=\$${datadir}/man \
  52. --infodir=\$${datadir}/info \
  53. --sysconfdir=/etc \
  54. --sbindir=/sbin \
  55. --localstatedir=/var \
  56. --with-devlibdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
  57. --without-libmd \
  58. --with-libz \
  59. --with-liblzma \
  60. --with-libbz2
  61. # Build the package in build-tree
  62. build-indep build-arch build: build-tree/config.status
  63. dh_testdir
  64. cd build-tree && $(MAKE)
  65. # Run the test suites
  66. check: build
  67. dh_testdir
  68. ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
  69. cd build-tree && $(MAKE) VERBOSE=1 TESTSUITEFLAGS=--verbose \
  70. TEST_PARALLEL=$(NUMJOBS) check
  71. endif
  72. # Install the package underneath debian/tmp
  73. install: check
  74. dh_testdir
  75. dh_testroot
  76. dh_prep
  77. dh_installdirs
  78. cd build-tree && $(MAKE) DESTDIR=$(D) install
  79. define dpkg-installmanl10n
  80. for f in `sed -e 's:\*:*/*:' debian/$(1).manpages`; do \
  81. test -e $$f && \
  82. install -D $$f `echo $$f | sed -e 's:^debian/tmp:debian/$(1):'`; \
  83. done
  84. endef
  85. # Put together the dpkg and dselect packages
  86. binary-arch: install
  87. dh_testdir -a
  88. dh_testroot -a
  89. dh_install -a
  90. dh_installcron -a
  91. dh_installlogrotate -a
  92. dh_installchangelogs -a ChangeLog*
  93. dh_installdocs -a
  94. $(call dpkg-installmanl10n,dpkg)
  95. $(call dpkg-installmanl10n,dselect)
  96. dh_installman -a
  97. dh_link -a
  98. dh_lintian -a
  99. dh_strip -a
  100. dh_compress -a
  101. dh_fixperms -a
  102. dh_installdeb -a
  103. dh_shlibdeps -a
  104. dh_gencontrol -a
  105. dh_md5sums -a
  106. dh_builddeb -a
  107. # Put together the dpkg-dev package
  108. binary-indep: install
  109. dh_testdir -i
  110. dh_testroot -i
  111. dh_install -i
  112. dh_installcron -i
  113. dh_installchangelogs -i ChangeLog*
  114. dh_installdocs -i
  115. $(call dpkg-installmanl10n,dpkg-dev)
  116. dh_installman -i
  117. dh_link -i
  118. dh_lintian -i
  119. # The perl modules should not depend on a specific interpreter.
  120. dh_perl -i -Nlibdpkg-perl
  121. dh_compress -i
  122. dh_fixperms -i
  123. dh_installdeb -i
  124. dh_gencontrol -i
  125. dh_md5sums -i
  126. dh_builddeb -i
  127. binary: binary-arch binary-indep
  128. # Clean up the mess we made
  129. clean:
  130. dh_testdir
  131. [ ! -f Makefile ] || $(MAKE) distclean
  132. rm -rf build-tree
  133. dh_clean
  134. .PHONY: build check install binary-arch binary-indep binary clean