Browse Source

doc: Cleanup software requirements in README

Add a reference to the coding-style.txt for the perl requirements. Move
po4a to building from git section.
Guillem Jover 4 years ago
parent
commit
4df257da3b
2 changed files with 10 additions and 6 deletions
  1. 6 6
      README
  2. 4 0
      debian/changelog

+ 6 - 6
README

@@ -53,6 +53,10 @@ the git tree:
 
 the source should be roughly equivalent to the distributed tar source.
 
+To enable translated documentation this software will be needed:
+
+  po4a >= 0.43
+
 
 Building from tar source
 ------------------------
@@ -60,9 +64,9 @@ Building from tar source
 The minimum software required to configure and build dpkg from a tarball is:
 
   C89 compiler with few C99 extensions (see doc/coding-style.txt)
-  GNU make
+  perl (see doc/coding-style.txt)
   pkg-config
-  perl
+  GNU make
 
 To enable optional functionality or programs, this software might be needed:
 
@@ -96,10 +100,6 @@ will be needed:
   doxygen
   dot
 
-To enable translated documentation this software will be needed:
-
-  po4a >= 0.43
-
 To enable code coverage («./configure --enable-coverage; make coverage»)
 this software is needed:
 

+ 4 - 0
debian/changelog

@@ -1,5 +1,9 @@
 dpkg (1.18.19) UNRELEASED; urgency=medium
 
+  [ Guillem Jover ]
+  * Documentation:
+    - Cleanup software requirements in README.
+
   [ Updated programs translations ]
   * German (Sven Joachim).