rules 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. #!/usr/bin/make -f
  2. # Copyright (C) 2009, 2016 Julian Andres Klode <jak@debian.org>
  3. #
  4. # Free Software, licensed under the GPL-2 or (at your option) any later version.
  5. export DEB_LDFLAGS_MAINT_APPEND := -Wl,--as-needed
  6. export DEB_BUILD_MAINT_OPTIONS := hardening=+all
  7. # do not fail as we are just experimenting with symbol files for now
  8. export DPKG_GENSYMBOLS_CHECK_LEVEL=0
  9. %:
  10. dh $@ --with systemd --parallel --buildsystem=cmake
  11. override_dh_install-indep:
  12. dh_movefiles
  13. dh_install --list-missing
  14. find debian/libapt-pkg-doc/usr/share/doc/libapt-pkg-doc/html \( -name '*.md5' -o -name '*.map' \) -delete
  15. override_dh_install-arch:
  16. dh_movefiles
  17. dh_install --fail-missing
  18. install -m 644 debian/apt.conf.autoremove debian/apt/etc/apt/apt.conf.d/01autoremove
  19. install -m 755 debian/apt.auto-removal.sh debian/apt/etc/kernel/postinst.d/apt-auto-removal
  20. override_dh_gencontrol:
  21. dh_gencontrol -- -Vapt:keyring="$(shell ./vendor/getinfo keyring-package)"
  22. override_dh_installcron:
  23. dh_installcron --name=apt-compat
  24. override_dh_auto_configure-arch: flags=-DWITH_DOC=OFF
  25. override_dh_auto_configure-indep: flags=-DWITH_DOC=ON
  26. override_dh_auto_configure-arch override_dh_auto_configure-indep:
  27. dh_auto_configure -- $(flags)